7 Machine
Home / Arctic Cat

Are Arctic Cats Reliable

rebel1022852010-08-09 22:26:20 +0000 #1
Buddy of mine has an 06 700 EFI limited edition.... blah blah blah... with 28" tires...

he has went through 4 rear half shafts and now he snapped the shaft that goes from the gear box to the rear end...

The only thing its reliable at is breaking down.
MTImodquad2010-08-09 22:36:57 +0000 #2
I have a few AC's and I thik they are very reliable. Any machine will start to break once you start adding mods. I have just about everything possible done to mine and yeah they break. That's part of building them up, it's expectted.

Arctic Cats to me fall under this phrase...Reliability thru simplicity. Looka t eh guys racing wspa and baja, those are pretty close to stock bikes. AC is the only one not breaking frames and such. Those guys pound the snot out of them too.

-Marty
Mud Narc2010-08-09 22:42:38 +0000 #3
Two of the guys that ride with us have AC's and the only problems they have is overheating and the speed O cluster not working. Overheating was taken care of by relocating radiator but the other I'm not sure.
TorkMonster2010-08-09 23:21:00 +0000 #4
I know I have seen some Artic Cats abused, both new ones AND used ones...

The things I mostly saw were axles, and shafts.. This is with tires 29.5 and above... With that much meat, like MTImodquad: www.mudinmyblood.net/forum/member.php?u=40 said, it is expected, atleast it would be for me....

I have seen some OLD ones still running around, that honestly, I dont know HOW they were still running much less still together...

Werent the older ones, the motors more to the rear or something like that??

I tell ya what, if they come out with a 1000cc TWIN Mud Pro, I would seriously have to look at it....
MTImodquad2010-08-09 22:44:04 +0000 #5
Well I think you will be looking come this fall there TorkMonster. I know I will be. 2010 it's said to happen....
KMKjr2010-08-09 23:31:08 +0000 #6
Quote:

Originally Posted by Mud Narc

Two of the guys that ride with us have AC's and the only problems they have is overheating and the speed O cluster not working. Overheating was taken care of by relocating radiator but the other I'm not sure.

Friend of my fathers had a cluster problem and found ouf after replacing several under warranty, then warranty ran out, you can just reset them (guess if you start it before you power up the cluster if f's up).

Packed the connector with di-electric grease, reset it (battery disconnect) and has not had a problem since.
SWAMPMAFIA2010-08-09 23:10:20 +0000 #7
I owed an ole 400m, thing was a tank. Have some pics of her on here, my wife was mad when i sold it. I got her a grizz and she said i quote,"Its rides really good but i could run over more stuff with the putty tat"lol
Yesterday2010-08-10 00:45:52 +0000 #8
Quote:

Originally Posted by SWAMPMAFIA

I owed an ole 400m, thing was a tank. Have some pics of her on here, my wife was mad when i sold it. I got her a grizz and she said i quote,"Its rides really good but i could run over more stuff with the putty tat"lol

you've got some pretty cool pics in your albums. you should make one into an avatar
Bootlegger2010-08-09 23:19:05 +0000 #9
I like them....I think they are a tough bike.

Reply

Name:
Content:


Other posts in this category