7 Machine
Home / BMW

06 325i won't start

jkwakopo2010-08-18 16:26:16 +0000 #1
Weird... I know it's not my battery because I changed it last year. My car has little bit less than 90000 miles. When I put the key in, my car didn't start. No, it wasn't my steering wheel locking up. Radio works, wipers do work, and I can change my gears... Just engine didn't start. Everything else work fine... No warranties, and nearest BMW dealer is 50 miles away. Anyone had this problem before? Back in korea (I have 2004 x3 there), I had problems with coils. BMW road assistant came out, fixed it, and charged like $150 for couple coils without warranties (tried to give him $50 tip but of course he didnt take it). I guess here in US, we only get that if we are under warranty. Please help me guys. Can I take my car to local sears ( I already changed oil, brake rotors and pads, and tires) or should I take it to Roanoke, VA BMW dealership? Please help!!!
jkwakopo2010-08-18 16:39:32 +0000 #2
Sorry if I put this post in wrong thread.... I was really frustrated. This never happened to me before.
Chriztofor2010-08-18 16:56:40 +0000 #3
See my sig. in order to diagnose future problems, but you may want to take it to an INDY. A stealer will destroy you.
jkwakopo2010-08-18 16:43:51 +0000 #4
Quote:

Originally Posted by Chriztofor

See my sig. in order to diagnose future problems, but you may want to take it to an INDY. A stealer will destroy you.

Im kind of urgent but thanks for your help
x5to330i2010-08-18 17:42:34 +0000 #5
you can probably take it to any mechanic to atleast find out what is wrong. just get them to plug up the computer.
kyleJB3282010-08-18 18:30:28 +0000 #6
google 'foreign auto mechanic' in your area...atleast they can diagnose and maybe even fix it asap.
Barbera3352010-08-18 18:13:31 +0000 #7
Your problem is most likey the starter. I would check the solenoid for power while an assistant presses the brake pedal and attempts to start your car. This is a known failure point on E9x vehicles. Especially the 06 model year.
jkwakopo2010-08-18 17:58:34 +0000 #8
Quote:

Originally Posted by Barbera335

Your problem is most likey the starter. I would check the solenoid for power while an assistant presses the brake pedal and attempts to start your car. This is a known failure point on E9x vehicles. Especially the 06 model year.

What's solenoid? Where is it located at?
Barbera3352010-08-18 17:59:46 +0000 #9
It is mounted to the top of the starter, the whole starter solenoid assembly is mounted under the intake manifold on the trans bell housing. If you look through the intake runners between cylinder 5 and 6 you can see it.
texasbmw325i2010-08-18 17:55:14 +0000 #10
same thing happened to my car today. had to get it towed to the dealer and it was the battery. cost me 350!
jkwakopo2010-08-18 21:35:58 +0000 #11
Thanks for all inputs, Im taking it to the service center waiting for the tow truck... I'll keep up an update later.
jkwakopo2010-08-18 17:33:49 +0000 #12
well, here is an update... dropped my car off local shop which had computer to see what's wrong with it... Well, mechenic first thought it was the key box... so he ordered a new key box ($120) but that's wasn't the problem.. computer said everything is good... and he can't figure out why.... so looks like now i have to take it to the bmw dealer... he did say, sometimes anti theft locks up and if you use your key to unlock/lock few times to unjam it, it should work..but mine doesn't... he thinks somehow the anti-theft system is not getting the signal it needs, so it cuts the ignition off. yes his store has equipment to diagnosis newer bmws but he can't reset the anti theft.... only BMW dealer can... so... i'm stuck here again... anyone ever had same problem... nothing wrong with anything according to this mech's comp but car doesn't start..lol...

Reply

Name:
Content:


Other posts in this category