7 Machine
Home / Can-Am/BRP

Ride MUD????

TorkMonster2010-08-10 02:38:20 +0000 #1
Well, I am NOT a big mudder, bud, rode mud, like big mud, ONE TIME.....

THIS is what happened to mine...





Sorry bout the bad pics, was with my phone...

But that lil jewel is the PRE-FILTER on the fuel pump inside the fuel tank..

I rode creek/water all summer long, rode mud ONE time in the winter.. MAN...

That thing is CLOGGED with mud...

I noticed the next time I filled up with gas, that I had a lil mud or remnance of mud inside the filler neck, but didn't think nothing of it.. And didn't NOTICE anything for atleast 7-8 tanks later...

Yesterday on a ride in Crel Springs Illinois, I couldn't get it to run hardly at ALL.... I was thinking fuel pump, along with probus.... Well, that cutting out, and dying was due to that lil thing..

WoW, what a sorry excuse for a fuel CAP... MAN....
Yesterday2010-08-10 02:41:01 +0000 #2
w0w
mrkd12010-08-10 02:48:44 +0000 #3
Almost looks like somebody dumped the dirt instead of sugar.. never saw that before..mabey your caps missing a gasket..
Polaris4252010-08-10 02:54:35 +0000 #4
ouch... there's got to be something missing w/ that cap, as many CAN's as Ive seen in the pits...
kawa6502010-08-10 02:55:50 +0000 #5
Man, not good to see!!!
TorkMonster2010-08-10 03:04:35 +0000 #6
Well, got her all cleaned up last night, started assembling it this morning. went to crank the key, and ....

Whuuuuuum POWWW!!! lol

She purring like she should again..... Thank GAWD!!!!

Now I just gotta run the tank vents, and I am making some kind of gasket for that cap....

Honestly, i only rode mud, once.. DEEP mud anyways..

I rode the creek all summer long and part of the winter and never had a problem...

Well, least I got it before something terrible happened.. I mean I would HATE to have to rebuild, and put all performance and HC pistons or something in it!!! LOL

Honestly I'm not ready to tear it down YET so I AM glad....

Now, off to go ride somewhere!!

Reply

Name:
Content:


Other posts in this category