7 Machine
Home / Kawasaki

brute back carb backfiring

camobruteforce2010-08-10 15:29:15 +0000 #1
I noticed at very slow speeds my 08 brute 650 would sound likeit had a small back fire, and when you would run it fast and let off it would backfire loud once. I pulled the air cleaner off and hit the throttle and you can see a really small backfire in the carb towards the rear of the bike. What could cause this? It did sit for about 8 months or so, but I have cleaned the fuel tank, ran premium fuel with sea foam as well. The bike has plenty of power and doesnt seem to be suffering power wise, it just wont idle, you have to feather the throttle lightly. Any suggestions as to what it could be?

thanks, and I am new to this
N2Otorious2010-08-10 15:36:03 +0000 #2
Did you use sta-bil: www.goldeagle.com/br.../stabil/default.aspx fuel stabilizer? the fuel we have today is crap, and will turn to tarnish rather quickly. I have to run stabil : www.goldeagle.com/br.../stabil/default.aspx in my lawnmower, due to tarnish. I guess I don't use the fuel in the tank often enough to not stabilize the fuel.

Pull the fuel bowls and see if you have tarnish, if you do, clean them, and pull your jets, mains and pilots, clean them and see what that does for ya.

filthyredneck08brute2010-08-10 15:44:24 +0000 #3
1 of my old 650 SRAs always had a repetitive little "pop" to it when I rode at slow speeds, it would idle though and it didnt backfire. I changed the jets out and prob went away. Dont know if yours is from tarnished fuel like N2Otorious suggested or maybe just needs jets. I switched the rear jet into the front carb and bought a little bigger jet for the rear carb, think it costed me about 3 bucks. My stepdad also just did this same thing to his 08 teryx. Sorry I couldnt provide a direct answer...just something I experienced before, hope it helps.

Reply

Name:
Content:


Other posts in this category