7 Machine
Home / Kawasaki

brute running bad

deerslayar2010-08-10 23:31:56 +0000 #1
ok I have a 06 brute 750 with snorkels, rejetted carbs,but dont know what jets the stealership put in. The problem is when im riding gas is coming out of the carb drains. The bike spits and sputters when accerlerating. I cleaned carbs to make sure the choke wasnt sticking,or the float wasnt messed up. Everthing looked good in carbs. And exhaust smells like gas, is this all a jetting problem making it run rich, or something else. Please any ideas will be helpful.
drtj2010-08-10 23:44:29 +0000 #2
Check vent tubes. Could be clogged. Or the floats may be stuck
srtlongbow1232010-08-10 23:49:41 +0000 #3
ok can you tell me the jet numbers for front then the rear and the mods you have and i can help you out
deerslayar2010-08-11 00:04:41 +0000 #4
well i dont have time today but hopefully tommorow i can take the carbs off and see what jets i have. As far as mods i got a clutch kit (wont affect anything), snorkels, k&n filter, and the jet kit. factory exhaust that i busted out the turbine.
srtlongbow1232010-08-11 00:16:30 +0000 #5
Well when you get in the carb let me know pm me your number and i will help you out
deerslayar2010-08-11 00:07:56 +0000 #6
ok i found my jet kit box lucky i kept it. The front carb main jet is a DJ144, and the back carb has a DJ150. The fuel needles are DNO227 hopefully that helps. If you need any other info let me know. Thanks for the help
srtlongbow1232010-08-11 01:44:51 +0000 #7
ok i think your air / fuel is off should be 2 1/2 out from closed

Reply

Name:
Content:


Other posts in this category