7 Machine
Home / Kawasaki

Carb jetting

mudintx2010-08-11 08:48:12 +0000 #1
Need help please! I just put on hmf full exhaust system and rejetted carbs 160 in rear carb and 165 in front, idles good runs good till mid range going into high range it starts sputtering. Have a/f screws at 2-1/2 turns and needels on #5 slot. Any ideas?
Bootlegger2010-08-11 09:01:53 +0000 #2
is it a 750? if so put your needles on the 4th notch from the top.
mudintx2010-08-11 09:26:18 +0000 #3
Bruteforce 750 2007 Had them on 4th still made no difference, to me it seems like it needs more air. Is it normal for pipes(full stainless steel) to get cherry red when you just sit there with throttle held?
BleednGreen682010-08-11 08:57:47 +0000 #4
Well sounds like you got yer main jets in wrong. Rear carb is the one that supposed to have the bigger main jet. Swap them around and try it. Also make sure you go up on the pilots like #40's. I put in #40 pilots in my 750 that came out of a 700 prairie. Works fine.
mudintx2010-08-11 09:23:47 +0000 #5
Sorry typed in backwards 160f/165r Are they #40 you can get at Kawasaki dealer?
cmills2010-08-11 09:27:12 +0000 #6
Sounds like the nut that connects handlebars to the seat is loose, LOL. If we get yo ride goin tonight are we still on for tomorrow??
mudintx2010-08-11 10:14:22 +0000 #7
Quote:

Originally Posted by cmills

Sounds like the nut that connects handlebars to the seat is loose, LOL. If we get yo ride goin tonight are we still on for tomorrow??

Yes sir!!!!

Reply

Name:
Content:


Other posts in this category