7 Machine
Home / Mud

Amsoil

phreebsd2010-08-15 12:20:47 +0000 #1
Anyone here use it? If so, where you getting it?
kawa6502010-08-15 12:22:44 +0000 #2
I use it, 20w50 in motor and front diff from the dealer about nine dollars a quart.
phreebsd2010-08-15 12:53:44 +0000 #3
You got a local dealer or something?

i just looked and i can order it direct
kawa6502010-08-15 12:58:47 +0000 #4
Just the Kawie dealer about 10 miles from me, thats the only place ive seen it around here
phreebsd2010-08-15 13:24:43 +0000 #5
oh. i didnt know the dealer carries amsoil. I saw engine ice and some other stuff on the shelves. I might have overlooked the amsoil. I'll have to give them a looksy.
Bootlegger2010-08-15 14:31:44 +0000 #6
You can get it online....I just use either Valvoline ATV oil or the Kawasaki oil. I am thinkig about switching to the Kawie 10w-40 Synthetic.
phreebsd2010-08-15 14:57:21 +0000 #7
im switching oil.

Not really for any good reason either..

Currently, my oil foams after high reving but i believe this to be from the Lucal oil stabilizer additive and not the lucas semi-synthetic motorcycle oil itself. Was thinking of running some good oil thru it and see if i get better results.

I was going to get some royal purple (they sell it at O'reilly's) but then I read an article from Amsoil about moly added to oil and they said Royal Purple adds moly. Though I can see it being a problem they said you will see it from the long oil change intervals (6 months to a year) and i dont plan on doing that on the brute. Certainly every 3 months...maybe more once I get the huge meats on it and it's under more stress all the time. i'll likely try some royal purple since it costs about the same as the lucas i buy.
cigaro2010-08-15 14:06:57 +0000 #8
I run Royal Purple in mine. No problems yet. Of course I never had a oil related problem when I was running the Exxon 15w40 I was getting from work.
jackman2010-08-15 16:30:47 +0000 #9
I run amsoil 20w50

Reply

Name:
Content:


Other posts in this category